import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)(?(?=\\d+_.{16}(?:EXE_CO|EXE_IN))(?<!\\d_.{16}CONTENT_ACCESS))|(?=(?:\\d+_.{16}(?:EXE_CO|EXE_IN))+(?:\\d+_.{16}CONTENT_ACCESS)+))(\\d+)_(.{16})(EXE_CO|EXE_IN|CONTENT_ACCESS)";
final String string = "1_11/08/2014 23:03EXE_IN1_11/08/2014 23:03EXE_CO2_12/08/2014 09:17CONTENT_ACCESS3_13/08/2014 09:17CONTENT_ACCESS\n\n"
+ "3_13/08/2014 09:17CONTENT_ACCESS1_11/08/2014 23:03EXE_IN2_11/08/2014 23:03EXE_IN3_13/08/2014 09:17CONTENT_ACCESS\n\n"
+ "1_11/08/2014 23:03EXE_IN2_12/08/2014 09:17CONTENT_ACCESS3_13/08/2014 09:17CONTENT_ACCESS\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}