#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:[\(])*([\d]{3,3})(?:[\)\.\ ])*([\d]{3,3})(?:[\-\.])*([\d]{4,4})"
Local $sString = "586.943.9341" & @CRLF & _
"5869439241" & @CRLF & _
"(586)123-4567" & @CRLF & _
"(586) 943-9341"
Local $sSubst = "$1-$2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)