use strict;
my $str = '586.943.9341
5869439241
(586)123-4567
(586) 943-9341';
my $regex = qr/(?:[\(])*([\d]{3,3})(?:[\)\.\ ])*([\d]{3,3})(?:[\-\.])*([\d]{4,4})/p;
my $subst = '$1-$2-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";