re = /(?:[\(])*([\d]{3,3})(?:[\)\.\ ])*([\d]{3,3})(?:[\-\.])*([\d]{4,4})/
str = '586.943.9341
5869439241
(586)123-4567
(586) 943-9341'
subst = '$1-$2-$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result