package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]\d\d?(?:,[1-9]\d\d?)*$`)
var str = `12,123,56,567,789,11
1,23,456
025,123,456
1234,56,78
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}