import re
regex = re.compile(r"^[1-9]\d\d?(?:,[1-9]\d\d?)*$", flags=re.MULTILINE)
test_str = ("12,123,56,567,789,11\n"
"1,23,456\n"
"025,123,456\n"
"1234,56,78\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")