// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]\d\d?(?:,[1-9]\d\d?)*$").unwrap();
let string = "12,123,56,567,789,11
1,23,456
025,123,456
1234,56,78
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}