import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (SessionID=\".*?\")?(?: .*(MsgType=\".*?\"))? ";
final String string = "2021-10-07 10:32:05,767 ERROR [LAWT2] blah.blah.blah - Message processing FAILED: <ExecutionReport blah=\"xxx\" foo=\"yyy\" SessionID=\"kkk\" MoreStuff=\"zz\"> Total time for which application threads were stopped: 0.0003858 seconds, Stopping threads took: 0.0000653 seconds\n"
+ "2021-10-07 10:31:32,902 ERROR [LAWT6] blah.blah.blah - Message processing FAILED: <NewOrderSingle SessionID=\"zkx\" TargetSubID=\"ttt\" Account=\"blah\" MsgType=\"D\" BookingTypeOverride=\"0\" Symbol=\"6316\" OtherField1=\"othervalue1\" Otherfield2=\"othervalue2\"/></D></NewOrderSingle>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}