$re = '/(?<=([a-z])|\d)(?=(?(1)\d|[a-z]))/mi';
$str = 'subject101
street45
45hgh';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;