import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]+\\d{0,80}$";
final String string = "a\n"
+ "a1\n"
+ "ab12\n"
+ "aAc\n"
+ "aAd12\n"
+ "aAd12345678901234567890123456789012345678901234567890123456789012345678901234567890\n"
+ "aAd123456789012345678901234567890123456789012345678901234567890123456789012345678901\n"
+ "1\n"
+ "1a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}