const regex = /^[a-zA-Z]+\d{0,80}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]+\\d{0,80}$', 'gm')
const str = `a
a1
ab12
aAc
aAd12
aAd12345678901234567890123456789012345678901234567890123456789012345678901234567890
aAd123456789012345678901234567890123456789012345678901234567890123456789012345678901
1
1a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}