const regex = /@(?:[a-z]-?)+(?<!-)\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@(?:[a-z]-?)+(?<!-)\\w+', 'g')
const str = `good
@good-1
@rizalibnu
@rizal-ibnu
@rizal_ibnu
@rizal ibnu
rizalibnu
@Rizalibnu
@muhamad-rizal-ibnu-abdulah
oriyodrsd wiueisdjfsdk sdkjfksd sdfsnfkh askjdksj zsdsjksjd sdas @muhamad-rizal-ibnu-abdulah `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}