#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9](?:[a-zA-Z0-9 ._-]*[a-zA-Z0-9])?\.[a-zA-Z0-9_-]+$"
Local $sString = "## BELOW SHOULD MATCH" & @CRLF & _
"web.config" & @CRLF & _
"httpd.conf" & @CRLF & _
"test.txt" & @CRLF & _
"1.1" & @CRLF & _
"my long file name.txt" & @CRLF & _
"" & @CRLF & _
"## BELOW SHOULD NOT MATCH" & @CRLF & _
"æøå.txt" & @CRLF & _
"hosts" & @CRLF & _
".gitignore" & @CRLF & _
".htaccess" & @CRLF & _
"test.t xt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")