import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " *(\\w+|\\/[^\\/\\\\]*(?:\\\\.[^\\/\\\\]*)*\\/) *";
final String string = "/some test/ -> next data\n"
+ "prev<-/now/->/how about this/ \n"
+ "asd<-/rege\\/x/\n"
+ "/\\/\\//\n"
+ "/\\\\/\n"
+ "/^\\d+$/ <- /\\./\n"
+ "/\\./ -> /\\d/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}