$re = '/-(.*)\((.*)\)/m';
$str = '-Quarter(18548748)
-Quarter(45786)
-Quarter(8378)
-Quarter(737863)
-OUTSOLE 01(87678)
-OUTSOLE 01(75786)
-OUTSOLE 01(434+67)
-OUTSOLE 01(786378+)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);