# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@[^@]+@(?!.*@)//g;t' <<< "<pattern>@this is a statement@ @this is also a statement@</pattern>"