use strict;
my $str = '<pattern>@this is a statement@ @this is also a statement@</pattern>';
my $regex = qr/@[^@]+@(?!.*@)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";