re = /@[^@]+@(?!.*@)/
str = '<pattern>@this is a statement@ @this is also a statement@</pattern>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result