package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2}(\-| ){1}\w+(\-| ){1}\d{4}$`)
var str = `21-05112-2001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}