using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s+\.\s+(\d+)";
string substitution = @"$1.$2";
string input = @"Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}