$re = '/(\d+)\s+\.\s+(\d+)/m';
$str = 'Personal Expenses $ 14 . 56, Meals $ 65 . 54, Medical Bills $ 205 . 36';
$subst = "$1.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;