const regex = /<img src=".*?\/([A-Z0-9]+)\.\w+"\s*\/><img src=".*?\/([A-Z0-9]+)\.\w+"\s*\/>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img src=".*?\\\/([A-Z0-9]+)\\.\\w+"\\s*\\\/><img src=".*?\\\/([A-Z0-9]+)\\.\\w+"\\s*\\\/>', 'gm')
const str = `<img src="http://www.example.com/app_res/emoji/1F60A.png" /><img src="http://www.example.com/app_res/emoji/1F389.png" />
<img src="http://www.example.com/app_res/emoji/1F61E.png" /><img src="http://www.example.com/app_res/emoji/1F339.png" />`;
const subst = `&#x$1; &#x$2;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);