$re = '/^(.+[0-9]+.[0-9]+\.(png|gif|jpe?g)\.?(webp)?)$/m';
$str = '/HOSTACC/public_html/fx/upd/y-icon-sprite-213x300.png
/HOSTACC/public_html/fx/upd/01/desx-yopy-small-150x150.png
/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png
/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png.webp
/HOSTACC/public_html/fx/upd/ex/new/old-storage-720x500.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);