// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+[0-9]+.[0-9]+\.(png|gif|jpe?g)\.?(webp)?)$").unwrap();
let string = "/HOSTACC/public_html/fx/upd/y-icon-sprite-213x300.png
/HOSTACC/public_html/fx/upd/01/desx-yopy-small-150x150.png
/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png
/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png.webp
/HOSTACC/public_html/fx/upd/ex/new/old-storage-720x500.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}