using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\w\s\()\w+\s\d+|(?<=\w\s\()\w+\s+\w+\s\d+";
string input = @"(ABC 123) Text string (DEF 456)
(ABC 123) Text string (DEFG 123)
(ABC 123) Text string (DEFG ABC)
(ABC 123) Text string (123)
(ABC 123) Text string (ABC DEF 123)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}