import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\w\\s\\()\\w+\\s\\d+|(?<=\\w\\s\\()\\w+\\s+\\w+\\s\\d+";
final String string = "(ABC 123) Text string (DEF 456)\n\n"
+ "(ABC 123) Text string (DEFG 123)\n\n"
+ "(ABC 123) Text string (DEFG ABC)\n\n"
+ "(ABC 123) Text string (123)\n\n"
+ "(ABC 123) Text string (ABC DEF 123)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}