$re = '/(?<=\w\s\()\w+\s\d+|(?<=\w\s\()\w+\s+\w+\s\d+/m';
$str = '(ABC 123) Text string (DEF 456)
(ABC 123) Text string (DEFG 123)
(ABC 123) Text string (DEFG ABC)
(ABC 123) Text string (123)
(ABC 123) Text string (ABC DEF 123)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);