const regex = /(?:EUR|USD|GBP|\G(?!^)\d+(?:\.\d+)?)\K( +)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:EUR|USD|GBP|\\G(?!^)\\d+(?:\\.\\d+)?)\\K( +)', 'gm')
const str = `EUR 1.2
EUR 1.23
EUR 12
EUR 123
EUR 12 Mio.
EUR 12 345 Mio.
GBP 1 123 456 789 Mio.
USD 12 million
EUR 1.23 billion`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);