import Foundation
let pattern = ##"^(?=^.*[a-z]#[a-z].*$|^.*\b[a-z0-9][a-z]#[a-z][a-z0-9]\b.*$)(?!.*[0-9]#[0-9]|.*[a-z]#[0-9]|.*[0-9]#[a-z]|.*[\s,^]#[\s,^]).*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
ex_date( ds23d#d4ff5 )
ex_date( asa#ss32as, #, s3ds#sdsd)
ex_date12(asa#ss32as,#,s3ds#sdsd)
( asa#ss32as, a#b, s3ds#sdsd)
date( asa#ss32as, #, s3ds#sdsd, a#b)
ex_date( asa#ss32as, a#b, s3ds#sdsd, 4#5)
ewe#ewe
we#ere, er2e#er3e, #
p_price(we#ee)
p_date( we#rer , )
p_car ( df#e ,)
re#ee , erer#r,
#wewqwq
ddf$%^#gfg^h
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)