using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[^\d](19|20)\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])$";
string input = @"fileNamePrefix_20171219
fileNamePrefix_20170019
fileNamePrefix_20171200
fileNamePrefix_19631219
fileNamePrefix_18631219
fileNamePrefix_20171319
fileNamePrefix_20171240
fileNamePrefix_20171219131415111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}