import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[^\\d](19|20)\\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\\d|3[01])$";
final String string = "fileNamePrefix_20171219\n"
+ "fileNamePrefix_20170019\n"
+ "fileNamePrefix_20171200\n"
+ "fileNamePrefix_19631219\n"
+ "fileNamePrefix_18631219\n"
+ "fileNamePrefix_20171319\n"
+ "fileNamePrefix_20171240\n"
+ "fileNamePrefix_20171219131415111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}