// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*[^\d](19|20)\d{2}(0[1-9]|1[0-2])(0[1-9]|[12]\d|3[01])$").unwrap();
let string = "fileNamePrefix_20171219
fileNamePrefix_20170019
fileNamePrefix_20171200
fileNamePrefix_19631219
fileNamePrefix_18631219
fileNamePrefix_20171319
fileNamePrefix_20171240
fileNamePrefix_20171219131415111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}