package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\D*(\d+\s+\w+).*`)
var str = `Psychologist - 7 years on the website, online`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}