use strict;
my $str = 'Psychologist - 7 years on the website, online';
my $regex = qr/\D*(\d+\s+\w+).*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";