re = /^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[#?!@$%^&*-]).{6,}$/
str = 'Adm1nisTRat*r69'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end