re = /(country=).*?(;|$)/i
str = '/uk/flights/results/country=BG;from-city=Kiev;from=IEV,KBP;to=BOJ,PDV,SOF,VAR;dates=2018-07-15,2018-07-29/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end