import Foundation
let pattern = #"(country=).*?(;|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"/uk/flights/results/country=BG;from-city=Kiev;from=IEV,KBP;to=BOJ,PDV,SOF,VAR;dates=2018-07-15,2018-07-29/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}