re = /^([a-zA-Z]+) ?([1-9]+)[, ]*[0-9]{,2}:[0-9]{,2}[^,]+, ?T=([-0-9]+)degr?/m
str = '# Measurements started
Sep 9, 9:05, T=22deg
SEP 9, 10:15, T=25deg
# Taking a coffee break
Sep 9, 11:15, T=-10deg
# Weekend
Sept 12, 09:00AM, T=32deg
Oct12 13:00, T=32degr'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end