#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>bnd\d{0,3}?)_(?<secondaryId>all|0[1-9]|[1-9][1-9])(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$"
Local $sString = "Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_all_r1.indd" & @CRLF & _
"Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_01_r1.indd" & @CRLF & _
"Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_11_r1.indd" & @CRLF & _
"Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_111_r1.indd" & @CRLF & _
"Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_00_r1.indd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")