using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<s((pan)?(up)?)[^>]*>.+<\/s\1>";
string input = @"<span> foo</span>
<sup> foo</sup>
<span> foo</span>
<sup> foo</sup>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}