import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<s((pan)?(up)?)[^>]*>.+<\\/s\\1>";
final String string = "<span> foo</span>\n"
+ "<sup> foo</sup>\n"
+ "<span> foo</span>\n"
+ "<sup> foo</sup>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}