re = /<s((pan)?(up)?)[^>]*>.+<\/s\1>/i
str = '<span> foo</span>
<sup> foo</sup>
<span> foo</span>
<sup> foo</sup>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end