// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m),"sql_queries":".*?,""#).unwrap();
let string = "{\"method\":\"GET\",\"path\":\"/REDACTED\",\"format\":\"json\",\"controller\":\"REDACTED\",\"action\":\"validate_token\",\"status\":200,\"duration\":30.26,\"view\":2.67,\"db\":5.88,\"pid\":10109,\"sql_queries\":\"' = 65593\\nUser Load (0.86) SELECT `users`.* FROM `users` WHERE `users`.`id` 3:59:58', `tokens` = '{\\\\\\\"REDACTED\\\\\\\":{\\\\\\\"token\\\\\\\":\\\\\\\"REDACTED/W\\\\\\\",\\\\\\\"expiry\\\\\\\":1550795150},\\\\\\\"REDACTED\\\\\\\":{\\\\\\\"token\\\\\\\":\\\\\\\"REDACTED/\\\\\\\",\\\\\\\"expiry\\\\\\\":1550795151},\\\\\\\"REDACTED\\\\\\\":{\\\\\\\"token\\\\\\\":\\\\\\REDACTED\\\\\",\\\\\\\"expiry\\\\\\\":1550795151},\\\\\\\"REDACTED\\\\\\\":{\\\\\\\"token\\\\\\\":\\\\\\\"REDACTED\\\\\\\",\\\\\\\"expiry\\\\\\\":1550795152},\\\\\\\"REDACTED\\\\\\\":{\\\\\\\"token\\\\\\\":\\\\\\\"$REDACTED\\\\\\\",\\\\\\\"expiry\\\\\\\":1550795152},\\\\\\\"REDACTED-g\\\\\\\":{\\\\\\\"token\\\\\\\":\\\\\\\"$REDACTED\\\\\\\",\\\\\\\"expiry\\\\\\\":1550795153},\\\\\\\"REDACTED\\\\\\\":{\\\\\\\"token\\\\\\\":\\\\\\\"REDACTED\\\\\\\",\\\\\\\"expiry\\\\\\\":1550795154},\\\\\\\"REDACTED\\\\\\\":{\\\\\\\"token\\\\\\\":\\\\\\\"REDACTED\\\\\\\",\\\\\\\"expiry\\\\\\\":1550800798}}' WHERE `users`.`id` = 65593\\n (0.98) COMMIT'\",\"@timestamp\":\"2019-02-21T23:59:58.015Z\",\"@version\":\"1\",\"message\":\"[200] GET / \"}";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}