Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<!cpc|accounts\.)(google|bing|search\.yahoo|search\.myway|yandex|duckduckgo|ecosia|search\.tb\.ask|baidu)(?!.*cpc)
/
gm
Input 1
1
New
google/cpc/[google][cpc][house][sale] google/cpc/[google][cpc][condo][sale] accounts.google.com.sg accounts.google.co.id google.com google.com.ph google.co.th bing.com google.co.uk com.google.android.googlequicksearchbox google.com.sg google.com.au google.com.vn google.ca google.co.id google.com.hk search.yahoo.com duckduckgo.com google.de ph.search.yahoo.com google.co.in google.fr google.co.jp google.co.kr google.com.my google.ae google.se google.ch int.search.myway.com yandex.ru google.ru google.com.tw google.nl cn.bing.com ecosia.org google.it google.dk google.co.nz int.search.tb.ask.com search.yahoo.co.jp google.co.za google.no google.es google.be th.search.yahoo.com google.fi baidu.com google.ie google.com.tr uk.search.yahoo.com