import Foundation
let pattern = #"^(?:v)?[0-9]+\.[0-9]+\.[0-9]+(?:\-*(beta|alpha){0,1}\.[0-9]+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.2.3
1.2.3-
1.2.3-alpha
1.2.3-beta
1.2.3-alpha.
1.2.3-beta.
1.2.3-alpha.12345
1.2.3-beta.1
v1.2.3
v1.2.3-alpha.1
v1.2.3-beta.1
v11111111111.22222222222.3333333333
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)