import Foundation
let pattern = #"((?<=[^\W[A-Z])[A-Z]|(?<=\S)[A-Z](?=[a-z]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
General Manager or VP Torrance, CARequired education
WordWordWord
DaveIsAFKRightNow!Cool
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)