# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!BM.)(?<=\W)(SetColor|SetAlpha|DrawRect|Delay|Flip|SetScale|SetVirtualResolution|CloseStream|GraphicsWidth|GraphicsHeight|VirtualResolutionWidth|VirtualResolutionHeight)(?=\W)"
test_str = ("\n"
"SetColor(0, 0, 0);\n"
" Delay(10);\n"
" Flip();\n"
" SetColor(0, 0, 0);\n"
" SetAlpha(- float(n) / Fade1);\n"
" DrawRect(0, 0,tApplication.ScrW(),tApplication.ScrH());\n"
" BM.SetAlpha(1);\n")
subst = "BM.$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.