package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\([^)]*\)|\w+`)
var str = `Sei proprio tu John Wayne ( E io chi sarei )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}