using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*)\s+(?P<log_time>.*),Microsoft-Windows-Security-Auditing,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)\s+(?P<audit_message>.*)";
string input = @"Audit Success,08/03/2017 18:57:56,Microsoft-Windows-Security-Auditing,4608,Security State Change,""Windows is starting up.
This event is logged when LSASS.EXE starts and the auditing subsystem is initialized.""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}