const regex = /Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*)\s+(?P<log_time>.*),Microsoft-Windows-Security-Auditing,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)\s+(?P<audit_message>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*)\\s+(?P<log_time>.*),Microsoft-Windows-Security-Auditing,(?P<event_id>\\d+),(?P<category>.*),(?P<event_message>.*)\\s+(?P<audit_message>.*)', 'g')
const str = `Audit Success,08/03/2017 18:57:56,Microsoft-Windows-Security-Auditing,4608,Security State Change,"Windows is starting up.
This event is logged when LSASS.EXE starts and the auditing subsystem is initialized."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}